CVE-2026-73073 Vim: Arbitrary Ex Command Execution in C Omni-Completion
Attackers can execute arbitrary commands via malicious tags files when users trigger C omni-completion in Vim.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-73073?
CVE-2026-73073 is a high-severity code injection vulnerability in Vim Vim, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0845, StructMembers() in runtime/autoload/ccomplete.vim constructs and executes a vimgrep command using an insufficiently escaped typeref: or typename: value from a tags file, allowing an unterminated collection followed by a command separator to execute arbitrary Ex and operating-system commands when a user invokes C omni-completion with CTRL-X CTRL-O on a member access whose type is resolved from that tags file. This issue is fixed in version 9.2.0845.
Which versions are affected by CVE-2026-73073?
It affects 1 product.
Linux distribution packages (26)
vim-X11 AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim-common AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim-data AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim-enhanced AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim-filesystem AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim-minimal AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
xxd AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim-X11 AlmaLinux:8 | All versions | 2:8.0.1763-32.el8_10 |
vim-common AlmaLinux:8 | All versions | 2:8.0.1763-32.el8_10 |
vim-enhanced AlmaLinux:8 | All versions | 2:8.0.1763-32.el8_10 |
vim-filesystem AlmaLinux:8 | All versions | 2:8.0.1763-32.el8_10 |
vim-minimal AlmaLinux:8 | All versions | 2:8.0.1763-32.el8_10 |
vim-X11 AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.23 |
vim-common AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.23 |
vim-enhanced AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.23 |
vim-filesystem AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.23 |
vim-minimal AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.23 |
vim Red Hat:enterprise_linux:10.2 | All versions | 2:9.1.083-9.el10_2.22 |
vim-common Red Hat:enterprise_linux:10.2 | All versions | 2:9.1.083-9.el10_2.22 |
vim-common Red Hat:enterprise_linux:8::appstream | All versions | 2:8.0.1763-32.el8_10 |
vim Red Hat:enterprise_linux:8::baseos | All versions | 2:8.0.1763-32.el8_10 |
vim-common Red Hat:enterprise_linux:9::appstream | All versions | 2:8.2.2637-26.el9_8.23 |
vim Red Hat:enterprise_linux:9::baseos | All versions | 2:8.2.2637-26.el9_8.23 |
vim Rocky Linux:10 | All versions | 2:9.1.083-9.el10_2.22 |
vim Rocky Linux:8 | All versions | 2:8.0.1763-32.el8_10 |
vim Rocky Linux:9 | All versions | 2:8.2.2637-26.el9_8.23 |
Products include Vim Vim.
How do I fix CVE-2026-73073?
Upgrade to a fixed version.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-73073 being exploited?
There is no known exploitation of CVE-2026-73073 in the wild and no public exploit code.
Other vulnerabilities in Vim Vim
Sources
Also known as ALPINE-CVE-2026-73073, ALSA-2026:75768, ALSA-2026:75769, ALSA-2026:77359, AZL-96767, BELL-CVE-2026-73073 and 18 more.