# CVE-2026-73085: Audiobookshelf: Refresh Token Accepted on Resource Endpoints

> Attackers can use refresh tokens to authenticate as users on resource endpoints, leading to account takeover in Audiobookshelf.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-798w-wv6c-2c3h

## What is CVE-2026-73085?

CVE-2026-73085 is a medium-severity authentication bypass vulnerability in advplyr audiobookshelf, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.36.0, the jwtAuthCheck function in server/auth/TokenManager.js treats JWTs with the refresh token type as bearer access tokens on API and WebSocket resource endpoints such as /api/me instead of restricting them to /auth/refresh, allowing refresh tokens to authenticate as the associated users. This issue is fixed in version 2.36.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-73085?


## How do I fix CVE-2026-73085?

No fix has been published for CVE-2026-73085 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73085 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73085 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73085 and fix it if it is affected.

What it is: CVE-2026-73085 is a medium-severity authentication bypass vulnerability in advplyr audiobookshelf, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73085 exists.

Affected product: advplyr audiobookshelf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73085/ (Markdown: https://insights.sbomify.com/CVE-2026-73085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73085
- OSV: https://osv.dev/vulnerability/CVE-2026-73085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73085/
Summaries are generated and may contain mistakes; the official description above is the record.
