{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7317 exists.","fix":"Upgrade getgrav/grav to 2.0.0-beta.2 or later.","what":"CVE-2026-7317 is a low-severity unsafe deserialization vulnerability in Grav CMS, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7317 and fix it if it is affected.\n\nWhat it is: CVE-2026-7317 is a low-severity unsafe deserialization vulnerability in Grav CMS, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7317 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7317/ (Markdown: https://insights.sbomify.com/CVE-2026-7317/index.md)","id":"CVE-2026-7317","markdown":"https://insights.sbomify.com/CVE-2026-7317/index.md","name":"CVE-2026-7317","record":{"aliases":["GHSA-gwfr-jfjf-92vv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Remote attackers can exploit unsafe deserialization in Grav CMS cache handling to execute arbitrary code, requiring high complexity and permissions.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability was found in Grav CMS up to 1.7.49.5/2.0.0-beta.1. Affected by this vulnerability is the function FileCache::doGet of the file system/src/Grav/Framework/Cache/Adapter/FileCache.php of the component Cache Value Handler. The manipulation results in deserialization. The attack may be launched remotely. The attack requires a high level of complexity. The exploitation appears to be difficult. The exploit has been made public and could be used. Upgrading to version 2.0.0-beta.2 addresses this issue. The patch is identified as c66dfeb5f. The affected component should be upgraded.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav CMS Cache Value FileCache.php doGet deserialization","id":"CVE-2026-7317","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"elie mcp-project research_server.py search_papers path traversal","id":"CVE-2026-7318"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-gwfr-jfjf-92vv"},{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-gwfr-jfjf-92vv"}],"prev":{"headline":"eiliyaabedini aider-mcp code_with_ai aider_mcp.py command injection","id":"CVE-2026-7316"},"products":["CMS"],"published":"2026-04-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-29","vendors":["Grav"]},"summary":"Remote attackers can exploit unsafe deserialization in Grav CMS cache handling to execute arbitrary code, requiring high complexity and permissions.","url":"https://insights.sbomify.com/CVE-2026-7317/"}