# CVE-2026-7317: Grav CMS Cache Value FileCache.php doGet deserialization

> Remote attackers can exploit unsafe deserialization in Grav CMS cache handling to execute arbitrary code, requiring high complexity and permissions.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** GHSA-gwfr-jfjf-92vv

## What is CVE-2026-7317?

CVE-2026-7317 is a low-severity unsafe deserialization vulnerability in Grav CMS, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in Grav CMS up to 1.7.49.5/2.0.0-beta.1. Affected by this vulnerability is the function FileCache::doGet of the file system/src/Grav/Framework/Cache/Adapter/FileCache.php of the component Cache Value Handler. The manipulation results in deserialization. The attack may be launched remotely. The attack requires a high level of complexity. The exploitation appears to be difficult. The exploit has been made public and could be used. Upgrading to version 2.0.0-beta.2 addresses this issue. The patch is identified as c66dfeb5f. The affected component should be upgraded.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-7317?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-7317?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-7317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7317 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7317 and fix it if it is affected.

What it is: CVE-2026-7317 is a low-severity unsafe deserialization vulnerability in Grav CMS, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7317 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7317/ (Markdown: https://insights.sbomify.com/CVE-2026-7317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7317
- OSV: https://osv.dev/vulnerability/CVE-2026-7317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7317/
Summaries are generated and may contain mistakes; the official description above is the record.
