CVE-2026-73192 Apache Sling XSS: XSS possible through XSSAPI.getValidHref()

Medium 6.1 Published Updated

An attacker can perform reflected cross-site scripting attacks via the XSSAPI.getValidHref() method in Apache Sling XSS.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-73192?

CVE-2026-73192 is a medium-severity cross-site scripting vulnerability in Apache Sling XSS, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability when using the XSSAPI.getValidHref() in Apache Sling XSS version 2.4.10 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack in every feature using this method. In order to successfully attack an application, the attacker needs to be able to submit a value which is not correctly sanitized by that library.

Upgrade to Apache Sling XSS >= 2.4.12

Weakness: CWE-79

Which versions are affected by CVE-2026-73192?

It affects 1 product.

Products include Apache Sling Xss Protection Api.

How do I fix CVE-2026-73192?

No fix has been published for CVE-2026-73192 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-73192 being exploited?

There is no known exploitation of CVE-2026-73192 in the wild and no public exploit code.

Sources

Also known as GHSA-84wv-6469-cpqp.

Is CVE-2026-73192 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free