# CVE-2026-73214: Denial of service in coturn

> Unauthenticated remote attackers can exhaust server memory via crafted DTLS packets, causing denial of service in coturn.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73214, GHSA-5x2p-4vqj-f6m4, MINI-q3gc-xjhq-mp56, UBUNTU-CVE-2026-73214

## What is CVE-2026-73214?

CVE-2026-73214 is a high-severity denial of service vulnerability in coturn, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Coturn is a free open source implementation of TURN and STUN Server. Prior to 4.16.0, dtls_server_input_handler() and create_new_connected_udp_socket() in src/apps/relay/dtls_listener.c retain OpenSSL dtls1_reassemble_fragment() state for a 35-byte fragmented ClientHello declaring a 650,000-byte handshake before cookie validation, allowing an unauthenticated remote sender using fresh UDP tuples to exhaust memory without TURN credentials, a completed handshake, a valid cookie, or source spoofing. This issue is fixed in version 4.16.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-73214?


## How do I fix CVE-2026-73214?

Upgrade to a fixed version.

## Is CVE-2026-73214 being exploited?

There is no known exploitation of CVE-2026-73214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73214 and fix it if it is affected.

What it is: CVE-2026-73214 is a high-severity denial of service vulnerability in coturn, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73214 in the wild and no public exploit code.

Affected product: coturn. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73214/ (Markdown: https://insights.sbomify.com/CVE-2026-73214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73214
- OSV: https://osv.dev/vulnerability/CVE-2026-73214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73214/
Summaries are generated and may contain mistakes; the official description above is the record.
