# CVE-2026-73218: Cursor: Sandbox escape via launching privileged containers

> Attackers can escape the sandbox to execute host commands and access user files by launching privileged containers if Docker tools are installed.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 13 Aug 2026

## What is CVE-2026-73218?

CVE-2026-73218 is a high-severity vulnerability in cursor, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cursor is a code editor built for programming with AI. Prior to 3.0.0, Cursor IDE for macOS allows an agent running in Auto-Run Sandbox mode, when Docker Desktop and the Dev Containers CLI are installed, to launch a privileged container and mount Docker's virtiofs0, granting read and write access to the user's home directory and enabling host command execution with the user's privileges without an additional permission prompt. This issue is fixed in version 3.0.0.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-73218?


## How do I fix CVE-2026-73218?

No fix has been published for CVE-2026-73218 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73218 being exploited?

There is no known exploitation of CVE-2026-73218 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73218 and fix it if it is affected.

What it is: CVE-2026-73218 is a high-severity vulnerability in cursor, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-73218 in the wild and no public exploit code.

Affected product: cursor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73218/ (Markdown: https://insights.sbomify.com/CVE-2026-73218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73218
- OSV: https://osv.dev/vulnerability/CVE-2026-73218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73218/
Summaries are generated and may contain mistakes; the official description above is the record.
