# CVE-2026-73226: Code injection in electerm

> An authenticated attacker can invoke arbitrary internal functions in electerm to execute commands or modify the filesystem due to missing method allowlists.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** GHSA-8chw-jwc5-8587

## What is CVE-2026-73226?

CVE-2026-73226 is a high-severity code injection vulnerability in electerm, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.15.186, electerm allows an authenticated WebSocket client to invoke unintended internal functions through client-controlled func values in upgrade-func in src/app/server/dispatch-center.js and handleFs in src/app/server/fs.js, exposing Upgrade and fsExport methods that can execute commands, open files, mutate the filesystem, or terminate the process. This issue is fixed in version 3.15.186.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-73226?


## How do I fix CVE-2026-73226?

No fix has been published for CVE-2026-73226 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73226 being exploited?

There is no known exploitation of CVE-2026-73226 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73226 and fix it if it is affected.

What it is: CVE-2026-73226 is a high-severity code injection vulnerability in electerm, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73226 in the wild and no public exploit code.

Affected product: electerm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73226/ (Markdown: https://insights.sbomify.com/CVE-2026-73226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73226
- OSV: https://osv.dev/vulnerability/CVE-2026-73226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73226/
Summaries are generated and may contain mistakes; the official description above is the record.
