# CVE-2026-73229: Django REST framework: AdminRenderer may disclose GET-protected data when rendering invalid write requests

> An attacker can view protected data by triggering an invalid write request, as the AdminRenderer bypasses permission checks during error rendering.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73229, ECHO-a4c9-31d4-2371, GHSA-g47c-3xmw-q6m2, MINI-2m9c-m3p8-9763, PYSEC-2026-3828, UBUNTU-CVE-2026-73229

## What is CVE-2026-73229?

CVE-2026-73229 is a medium-severity vulnerability in encode django-rest-framework, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Django REST framework is a powerful and flexible toolkit for building Web APIs. Prior to 3.17.2, Django REST Framework's rest_framework/renderers.py AdminRenderer.render() uses override_method() to simulate GET and directly invokes view.get() without view.check_permissions() while rendering an invalid write request, allowing a 400 Bad Request HTML response to disclose data from a GET representation that the requester is not permitted to access. This issue is fixed in version 3.17.2.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-73229?

3 open source packages ship an affected version, including djangorestframework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djangorestframework` | PyPI | All versions | 3.17.2 |
| `djangorestframework` | PyPI | All versions | 3.17.2 |
| `djangorestframework` | PyPI | All versions | 3.17.2 |

## How do I fix CVE-2026-73229?

Upgrade djangorestframework to 3.17.2 or later.

## Is CVE-2026-73229 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73229 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73229 and fix it if it is affected.

What it is: CVE-2026-73229 is a medium-severity vulnerability in encode django-rest-framework, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73229 exists.

Affected packages and fixed versions:
- djangorestframework (PyPI): affected all versions; fixed in 3.17.2
- djangorestframework (PyPI): affected all versions; fixed in 3.17.2
- djangorestframework (PyPI): affected all versions; fixed in 3.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73229/ (Markdown: https://insights.sbomify.com/CVE-2026-73229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73229
- OSV: https://osv.dev/vulnerability/CVE-2026-73229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73229/
Summaries are generated and may contain mistakes; the official description above is the record.
