# CVE-2026-73230: Ente: 2of3 cards v1 contain a checksum that enables offline guessing of low-entropy secrets

> An attacker with one 2of3 recovery card can offline guess low-entropy secrets due to a cleartext checksum, compromising Ente cloud account security.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-v6x7-rrch-9q9w

## What is CVE-2026-73230?

CVE-2026-73230 is a medium-severity vulnerability in ente, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Ente provides end-to-end encrypted cloud services and security tools. Prior to 2026.07.28, Ente 2of3 card format version 1 stored the secret byte length and 32-bit FNV-1a checksum in cleartext on every card, allowing someone with one card to test candidate secrets offline and recover low-entropy or predictable secrets. This issue is fixed in version 2026.07.28.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-73230?


## How do I fix CVE-2026-73230?

No fix has been published for CVE-2026-73230 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73230 being exploited?

There is no known exploitation of CVE-2026-73230 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73230 and fix it if it is affected.

What it is: CVE-2026-73230 is a medium-severity vulnerability in ente, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73230 in the wild and no public exploit code.

Affected product: ente. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73230/ (Markdown: https://insights.sbomify.com/CVE-2026-73230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73230
- OSV: https://osv.dev/vulnerability/CVE-2026-73230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73230/
Summaries are generated and may contain mistakes; the official description above is the record.
