# CVE-2026-73231: Faker: helpers.fake exploitable into arbritary code execution

> Attacker-controlled templates in Faker's helpers.fake method allow arbitrary JavaScript code execution via Function constructor access.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLSA-2026-1793299902, CLSA-2026-1793301523, GHSA-qxc2-j82w-r537, ROOT-APP-NPM-CVE-2026-73231

## What is CVE-2026-73231?

CVE-2026-73231 is a high-severity code injection vulnerability in faker-js faker, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Faker generates massive amounts of fake data in the browser and Node.js. Prior to 10.5.0, the faker.helpers.fake method in src/modules/helpers/eval.ts allows attacker-controlled fake templates to access the Function constructor through fakeEval.resolveProperty when a function returns another function, enabling arbitrary JavaScript code execution. This issue is fixed in version 10.5.0.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-73231?

2 open source packages ship an affected version, including @faker-js/faker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@faker-js/faker` | npm | All versions | 10.5.0 |
| `@faker-js/faker` | npm | All versions | 10.5.0 |

## How do I fix CVE-2026-73231?

Upgrade @faker-js/faker to 10.5.0 or later.

## Is CVE-2026-73231 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73231 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73231 and fix it if it is affected.

What it is: CVE-2026-73231 is a high-severity code injection vulnerability in faker-js faker, published on 11 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73231 exists.

Affected packages and fixed versions:
- @faker-js/faker (npm): affected all versions; fixed in 10.5.0
- @faker-js/faker (npm): affected all versions; fixed in 10.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73231/ (Markdown: https://insights.sbomify.com/CVE-2026-73231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73231
- OSV: https://osv.dev/vulnerability/CVE-2026-73231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73231/
Summaries are generated and may contain mistakes; the official description above is the record.
