CVE-2026-73236 Apache Syncope: Cross-Realm authorization bypass in delegated administration

High 7.5 Published Updated

Attackers can bypass delegated administration security checks in Apache Syncope due to flawed realm prefix matching, gaining unauthorized access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-73236?

CVE-2026-73236 is a high-severity authentication bypass vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Incorrect Authorization vulnerability in Apache Syncope.

Delegated administration security checks are based on Realm hierarchy and enforced via prefix matches. Due to incorrect implementation, two sibling Realms whose names begin with the same string cannot be correctly distinguished, resulting in incorrect authorization.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Weakness: CWE-863

Which versions are affected by CVE-2026-73236?

How do I fix CVE-2026-73236?

No fix has been published for CVE-2026-73236 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-73236 being exploited?

There is no known exploitation of CVE-2026-73236 in the wild and no public exploit code.

Sources

Also known as GHSA-82x7-r2q8-xr3h.

Is CVE-2026-73236 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free