# CVE-2026-73236: Apache Syncope: Cross-Realm authorization bypass in delegated administration

> Attackers can bypass delegated administration security checks in Apache Syncope due to flawed realm prefix matching, gaining unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-82x7-r2q8-xr3h

## What is CVE-2026-73236?

CVE-2026-73236 is a high-severity authentication bypass vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Apache Syncope.

Delegated administration security checks are based on Realm hierarchy and enforced via prefix matches.
Due to incorrect implementation, two sibling Realms whose names begin with the same string cannot be correctly distinguished, resulting in incorrect authorization.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-73236?


## How do I fix CVE-2026-73236?

No fix has been published for CVE-2026-73236 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73236 being exploited?

There is no known exploitation of CVE-2026-73236 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73236 and fix it if it is affected.

What it is: CVE-2026-73236 is a high-severity authentication bypass vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73236 in the wild and no public exploit code.

Affected product: Apache Syncope. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73236/ (Markdown: https://insights.sbomify.com/CVE-2026-73236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73236
- OSV: https://osv.dev/vulnerability/CVE-2026-73236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73236/
Summaries are generated and may contain mistakes; the official description above is the record.
