CVE-2026-73237 Apache Allura: XSS in markdown pipeline

Medium 6.1 Published Updated

Attackers can inject malicious scripts via Markdown, potentially stealing user sessions or executing code in Apache Allura.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-73237?

CVE-2026-73237 is a medium-severity cross-site scripting vulnerability in Apache Allura, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

XSS vulnerability in Markdown handling in Apache Allura.

This issue affects Apache Allura: from 1.10.0 before 1.19.1.

Users are recommended to upgrade to version 1.19.1, which fixes the issue.

Weakness: CWE-80

Which versions are affected by CVE-2026-73237?

It affects 1 product.

Products include Apache Allura.

How do I fix CVE-2026-73237?

No fix has been published for CVE-2026-73237 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-73237 being exploited?

There is no known exploitation of CVE-2026-73237 in the wild and no public exploit code.

Sources

Also known as GHSA-q6fp-vfv9-v477.

Is CVE-2026-73237 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free