# CVE-2026-73240: Apache Allura: Git command injection


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-29mg-2cr6-59xc

## What is CVE-2026-73240?

CVE-2026-73240 is a critical vulnerability in Apache Allura, published on 12 Aug 2026. 

### Official description

Specifically crafted inputs may lead to git argument injection in Apache Allura.

This issue affects Apache Allura: before 1.19.1.

Users are recommended to upgrade to version 1.19.1, which fixes the issue.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-73240?

It affects 1 product.


Products: Apache Allura.

## How do I fix CVE-2026-73240?

No fix has been published for CVE-2026-73240 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73240 being exploited?

There is no known exploitation of CVE-2026-73240 in the wild and no public exploit code.

## Other vulnerabilities in Apache Allura

- [CVE-2026-69223](https://insights.sbomify.com/CVE-2026-69223/): Apache Allura: Server-side request forgery (critical 9.1)
- [CVE-2024-36471](https://insights.sbomify.com/CVE-2024-36471/): Apache Allura: sensitive information exposure via DNS rebinding (high 7.5)
- [CVE-2018-1299](https://insights.sbomify.com/CVE-2018-1299/): Path traversal in Apache Allura (high 7.5)
- [CVE-2026-73239](https://insights.sbomify.com/CVE-2026-73239/): Apache Allura: Missing permission checks IDOR (medium 6.5)
- [CVE-2026-73237](https://insights.sbomify.com/CVE-2026-73237/): Apache Allura: XSS in markdown pipeline (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73240 and fix it if it is affected.

What it is: CVE-2026-73240 is a critical vulnerability in Apache Allura, published on 12 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-73240 in the wild and no public exploit code.

Affected product: Apache Allura. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73240/ (Markdown: https://insights.sbomify.com/CVE-2026-73240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73240
- OSV: https://osv.dev/vulnerability/CVE-2026-73240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73240/
Summaries are generated and may contain mistakes; the official description above is the record.
