{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-73251 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-73251 is a critical vulnerability in Cesanta Mongoose, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73251 and fix it if it is affected.\n\nWhat it is: CVE-2026-73251 is a critical vulnerability in Cesanta Mongoose, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73251 in the wild and no public exploit code.\n\nAffected product: Cesanta Mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73251/ (Markdown: https://insights.sbomify.com/CVE-2026-73251/index.md)","id":"CVE-2026-73251","markdown":"https://insights.sbomify.com/CVE-2026-73251/index.md","name":"CVE-2026-73251","record":{"aliases":["DEBIAN-CVE-2026-73251","GHSA-qj6j-2692-v2r8","JLSEC-2026-1376","UBUNTU-CVE-2026-73251"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Mongoose embedded web server","requires_auth":"none","summary":"A network attacker can impersonate a TLS server to a Mongoose client using a multi-certificate CA bundle, enabling traffic interception and modification.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mongoose","vendor":"cesanta"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Mongoose is an embedded web server and network library. Prior to 7.23, a network attacker can impersonate a TLS server to a Mongoose client configured with a multi-certificate CA bundle. In src/tls_builtin.c, the mg_tls_init() function stores the bundle in tls-\u003eca_bundle_der while tls-\u003eca_der.len remains zero, and mg_tls_recv_cert() uses tls_bundle_find() to accept a Common Name match without calling mg_tls_verify_cert_signature(). A forged self-signed certificate can therefore satisfy hostname and CertificateVerify checks and enable interception, credential disclosure, traffic modification, and malicious responses. This issue is fixed in version 7.23.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mongoose Built-in TLS: CA-bundle certificate chain accepted without any signature verification","id":"CVE-2026-73251","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"cesanta:mongoose","products":["cesanta:mongoose"],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Memory corruption in mongoose","id":"CVE-2026-73252"},"packages":[],"prev":{"headline":"Notepad++: Install-time PowerShell command injection through installation path","id":"CVE-2026-73250"},"products":["mongoose"],"published":"2026-08-20","related":[{"cvss_score":9.8,"headline":"Arbitrary File Write","id":"CVE-2022-25299","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-25756","kev_date_added":null,"published":"2020-09-18"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2019-19307","kev_date_added":null,"published":"2019-11-26"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-12951","kev_date_added":null,"published":"2019-06-24"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-20353","kev_date_added":null,"published":"2019-06-10"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-20354","kev_date_added":null,"published":"2019-06-10"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-20355","kev_date_added":null,"published":"2019-06-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["cesanta"]},"summary":"A network attacker can impersonate a TLS server to a Mongoose client using a multi-certificate CA bundle, enabling traffic interception and modification.","url":"https://insights.sbomify.com/CVE-2026-73251/"}