CVE-2026-73252 Memory corruption in mongoose

High 7.5 Published Updated

An unauthenticated remote attacker can cause a denial of service in Mongoose by triggering a heap out-of-bounds read via a malformed TLS record.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-73252?

CVE-2026-73252 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS stack selected by MG_TLS_BUILTIN in src/tls_builtin.c accepts a TLS 1.3 record whose decrypted size is exactly the 16-byte authentication tag with no plaintext or ContentType byte. In mg_tls_recv_record(), the msgsz length check permits that record and the recv_len calculation underflows to SIZE_MAX, so a later handshake step treats stale buffer contents as a trusted message with an effectively unbounded length. An unauthenticated malicious TLS peer can trigger a heap out-of-bounds read before certificate or Finished validation, causing a remote denial of service. This issue is fixed in version 7.23.

Weakness: CWE-191, CWE-125

Which versions are affected by CVE-2026-73252?

How do I fix CVE-2026-73252?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-73252 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73252 exists.

Sources

Also known as DEBIAN-CVE-2026-73252, GHSA-hq58-98f5-2wg3, UBUNTU-CVE-2026-73252.

Is CVE-2026-73252 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free