{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73252 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-73252 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73252 and fix it if it is affected.\n\nWhat it is: CVE-2026-73252 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73252 exists.\n\nAffected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73252/ (Markdown: https://insights.sbomify.com/CVE-2026-73252/index.md)","id":"CVE-2026-73252","markdown":"https://insights.sbomify.com/CVE-2026-73252/index.md","name":"CVE-2026-73252","record":{"aliases":["DEBIAN-CVE-2026-73252","GHSA-hq58-98f5-2wg3","UBUNTU-CVE-2026-73252"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Mongoose embedded web server","requires_auth":"none","summary":"An unauthenticated remote attacker can cause a denial of service in Mongoose by triggering a heap out-of-bounds read via a malformed TLS record.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS stack selected by MG_TLS_BUILTIN in src/tls_builtin.c accepts a TLS 1.3 record whose decrypted size is exactly the 16-byte authentication tag with no plaintext or ContentType byte. In mg_tls_recv_record(), the msgsz length check permits that record and the recv_len calculation underflows to SIZE_MAX, so a later handshake step treats stale buffer contents as a trusted message with an effectively unbounded length. An unauthenticated malicious TLS peer can trigger a heap out-of-bounds read before certificate or Finished validation, causing a remote denial of service. This issue is fixed in version 7.23.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in mongoose","id":"CVE-2026-73252","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Mongoose: TLS Hostname Verification Bypass via Overly Permissive Wildcard Matching","id":"CVE-2026-73253"},"packages":[],"prev":{"headline":"Mongoose Built-in TLS: CA-bundle certificate chain accepted without any signature verification","id":"CVE-2026-73251"},"products":["mongoose"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-14","vendors":["cesanta"]},"summary":"An unauthenticated remote attacker can cause a denial of service in Mongoose by triggering a heap out-of-bounds read via a malformed TLS record.","url":"https://insights.sbomify.com/CVE-2026-73252/"}