# CVE-2026-73252: Memory corruption in mongoose

> An unauthenticated remote attacker can cause a denial of service in Mongoose by triggering a heap out-of-bounds read via a malformed TLS record.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-73252, GHSA-hq58-98f5-2wg3, UBUNTU-CVE-2026-73252

## What is CVE-2026-73252?

CVE-2026-73252 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS stack selected by MG_TLS_BUILTIN in src/tls_builtin.c accepts a TLS 1.3 record whose decrypted size is exactly the 16-byte authentication tag with no plaintext or ContentType byte. In mg_tls_recv_record(), the msgsz length check permits that record and the recv_len calculation underflows to SIZE_MAX, so a later handshake step treats stale buffer contents as a trusted message with an effectively unbounded length. An unauthenticated malicious TLS peer can trigger a heap out-of-bounds read before certificate or Finished validation, causing a remote denial of service. This issue is fixed in version 7.23.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound)), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-73252?


## How do I fix CVE-2026-73252?

Upgrade to a fixed version.

## Is CVE-2026-73252 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73252 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73252 and fix it if it is affected.

What it is: CVE-2026-73252 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73252 exists.

Affected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73252/ (Markdown: https://insights.sbomify.com/CVE-2026-73252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73252
- OSV: https://osv.dev/vulnerability/CVE-2026-73252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73252/
Summaries are generated and may contain mistakes; the official description above is the record.
