# CVE-2026-73256: Mongoose: HTTP/1.0 detection off-by-one enables request smuggling via chunked TE


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73256, GHSA-mgp5-rjrv-h5j3, JLSEC-2026-1380, UBUNTU-CVE-2026-73256

## What is CVE-2026-73256?

CVE-2026-73256 is a critical vulnerability in Cesanta Mongoose, published on 20 Aug 2026. 

### Official description

Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-73256?

It affects 1 product.


Products: Cesanta Mongoose.

## How do I fix CVE-2026-73256?

Upgrade to a fixed version.

## Is CVE-2026-73256 being exploited?

There is no known exploitation of CVE-2026-73256 in the wild and no public exploit code.

## Other vulnerabilities in Cesanta Mongoose

- [CVE-2022-25299](https://insights.sbomify.com/CVE-2022-25299/): Arbitrary File Write (critical 9.8)
- [CVE-2020-25756](https://insights.sbomify.com/CVE-2020-25756/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-19307](https://insights.sbomify.com/CVE-2019-19307/): Integer overflow in n/a (critical 9.8)
- [CVE-2019-12951](https://insights.sbomify.com/CVE-2019-12951/): Memory corruption in n/a (critical 9.8)
- [CVE-2018-20353](https://insights.sbomify.com/CVE-2018-20353/): Use after free in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73256 and fix it if it is affected.

What it is: CVE-2026-73256 is a critical vulnerability in Cesanta Mongoose, published on 20 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-73256 in the wild and no public exploit code.

Affected product: Cesanta Mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73256/ (Markdown: https://insights.sbomify.com/CVE-2026-73256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73256
- OSV: https://osv.dev/vulnerability/CVE-2026-73256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73256/
Summaries are generated and may contain mistakes; the official description above is the record.
