{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73258 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-73258 is a medium-severity vulnerability in Cesanta Mongoose, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73258 and fix it if it is affected.\n\nWhat it is: CVE-2026-73258 is a medium-severity vulnerability in Cesanta Mongoose, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73258 exists.\n\nAffected product: Cesanta Mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73258/ (Markdown: https://insights.sbomify.com/CVE-2026-73258/index.md)","id":"CVE-2026-73258","markdown":"https://insights.sbomify.com/CVE-2026-73258/index.md","name":"CVE-2026-73258","record":{"aliases":["DEBIAN-CVE-2026-73258","GHSA-cc55-8v3r-59p8","JLSEC-2026-1382","UBUNTU-CVE-2026-73258"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mongoose embedded web server","requires_auth":"none","summary":"A logic error in Mongoose's multipart parser allows attackers to truncate headers or boundaries, potentially bypassing content-type checks and exposing sensitive data.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mongoose","vendor":"cesanta"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-697","name":"Incorrect Comparison"}],"description":"Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Mongoose: Multipart boundary/header scan logic error in mg_http_next_multipart","id":"CVE-2026-73258","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"cesanta:mongoose","products":["cesanta:mongoose"],"type":"other","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Mongoose: Reflected XSS via decoded URI in directory listing render","id":"CVE-2026-73259"},"packages":[],"prev":{"headline":"Mongoose: Content-Length + Transfer-Encoding coexistence enables request smuggling","id":"CVE-2026-73257"},"products":["mongoose"],"published":"2026-08-20","related":[{"cvss_score":9.8,"headline":"Arbitrary File Write","id":"CVE-2022-25299","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-25756","kev_date_added":null,"published":"2020-09-18"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2019-19307","kev_date_added":null,"published":"2019-11-26"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-12951","kev_date_added":null,"published":"2019-06-24"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-20353","kev_date_added":null,"published":"2019-06-10"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-20354","kev_date_added":null,"published":"2019-06-10"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-20355","kev_date_added":null,"published":"2019-06-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["cesanta"]},"summary":"A logic error in Mongoose's multipart parser allows attackers to truncate headers or boundaries, potentially bypassing content-type checks and exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2026-73258/"}