{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73260 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-73260 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73260 and fix it if it is affected.\n\nWhat it is: CVE-2026-73260 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73260 exists.\n\nAffected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73260/ (Markdown: https://insights.sbomify.com/CVE-2026-73260/index.md)","id":"CVE-2026-73260","markdown":"https://insights.sbomify.com/CVE-2026-73260/index.md","name":"CVE-2026-73260","record":{"aliases":["DEBIAN-CVE-2026-73260","GHSA-f6wr-mg35-p25g","UBUNTU-CVE-2026-73260"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Mongoose embedded web server","requires_auth":"none","summary":"An unauthenticated attacker can cause a denial of service via out-of-bounds read in Mongoose's built-in TLS parser when enabled.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Mongoose: Out-of-bounds Read via length-counter underflow in built-in TLS X.509 DER parser","id":"CVE-2026-73260","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Memory corruption in mongoose","id":"CVE-2026-73261"},"packages":[],"prev":{"headline":"Mongoose: Reflected XSS via decoded URI in directory listing render","id":"CVE-2026-73259"},"products":["mongoose"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["cesanta"]},"summary":"An unauthenticated attacker can cause a denial of service via out-of-bounds read in Mongoose's built-in TLS parser when enabled.","url":"https://insights.sbomify.com/CVE-2026-73260/"}