# CVE-2026-73260: Mongoose: Out-of-bounds Read via length-counter underflow in built-in TLS X.509 DER parser

> An unauthenticated attacker can cause a denial of service via out-of-bounds read in Mongoose's built-in TLS parser when enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-73260, GHSA-f6wr-mg35-p25g, UBUNTU-CVE-2026-73260

## What is CVE-2026-73260?

CVE-2026-73260 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-73260?


## How do I fix CVE-2026-73260?

Upgrade to a fixed version.

## Is CVE-2026-73260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73260 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73260 and fix it if it is affected.

What it is: CVE-2026-73260 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73260 exists.

Affected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73260/ (Markdown: https://insights.sbomify.com/CVE-2026-73260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73260
- OSV: https://osv.dev/vulnerability/CVE-2026-73260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73260/
Summaries are generated and may contain mistakes; the official description above is the record.
