# CVE-2026-73261: Memory corruption in mongoose

> An unauthenticated remote attacker can corrupt TCP MSS values via malformed options, causing silent data truncation and denial of service in Mongoose.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-73261, GHSA-3fmr-92g4-wchx, UBUNTU-CVE-2026-73261

## What is CVE-2026-73261?

CVE-2026-73261 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TCP/IP stack enabled by MG_ENABLE_TCPIP in src/net_builtin.c does not reject a TCP option whose declared opts[1] length exceeds the remaining option bytes. In handle_opt(), a NOP followed by a truncated MSS option causes opts[3] to be read outside the declared options area and used as the low byte of dmss. An unauthenticated remote peer can corrupt the per-connection MSS value so later mg_send() calls transmit truncated or zero-length application payloads while the TCP connection otherwise appears healthy. This issue is fixed in version 7.23.

Weakness: CWE-20 (Improper Input Validation), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-73261?


## How do I fix CVE-2026-73261?

Upgrade to a fixed version.

## Is CVE-2026-73261 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73261 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73261 and fix it if it is affected.

What it is: CVE-2026-73261 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73261 exists.

Affected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73261/ (Markdown: https://insights.sbomify.com/CVE-2026-73261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73261
- OSV: https://osv.dev/vulnerability/CVE-2026-73261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73261/
Summaries are generated and may contain mistakes; the official description above is the record.
