{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-73263 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-73263 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-73263 is a critical command injection vulnerability in prowler-cloud prowler, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73263 and fix it if it is affected.\n\nWhat it is: CVE-2026-73263 is a critical command injection vulnerability in prowler-cloud prowler, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73263 in the wild and no public exploit code.\n\nAffected product: prowler-cloud prowler. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73263/ (Markdown: https://insights.sbomify.com/CVE-2026-73263/index.md)","id":"CVE-2026-73263","markdown":"https://insights.sbomify.com/CVE-2026-73263/index.md","name":"CVE-2026-73263","record":{"aliases":["GHSA-ccqh-6cjc-wp4j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloud security platform","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands on Prowler App workers by submitting a malicious kubeconfig with a legacy GCP auth-provider.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Prowler: RCE on Prowler App workers via kubeconfig auth-provider cmd-path","id":"CVE-2026-73263","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Prowler: Server-Side Request Forgery (SSRF) in Lighthouse Provider","id":"CVE-2026-73264"},"packages":[],"prev":{"headline":"Prowler: Stored XSS in HTML reports through unescaped cloud resource tags","id":"CVE-2026-73262"},"products":["prowler"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-12","vendors":["prowler-cloud"]},"summary":"Attackers can execute arbitrary commands on Prowler App workers by submitting a malicious kubeconfig with a legacy GCP auth-provider.","url":"https://insights.sbomify.com/CVE-2026-73263/"}