# CVE-2026-73263: Prowler: RCE on Prowler App workers via kubeconfig auth-provider cmd-path

> Attackers can execute arbitrary commands on Prowler App workers by submitting a malicious kubeconfig with a legacy GCP auth-provider.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-ccqh-6cjc-wp4j

## What is CVE-2026-73263?

CVE-2026-73263 is a critical command injection vulnerability in prowler-cloud prowler, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-73263?


## How do I fix CVE-2026-73263?

No fix has been published for CVE-2026-73263 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73263 being exploited?

There is no known exploitation of CVE-2026-73263 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73263 and fix it if it is affected.

What it is: CVE-2026-73263 is a critical command injection vulnerability in prowler-cloud prowler, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73263 in the wild and no public exploit code.

Affected product: prowler-cloud prowler. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73263/ (Markdown: https://insights.sbomify.com/CVE-2026-73263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73263
- OSV: https://osv.dev/vulnerability/CVE-2026-73263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73263/
Summaries are generated and may contain mistakes; the official description above is the record.
