# CVE-2026-73278: Gitea WebAuthn bypass during OAuth and OIDC sign-in

> Attackers can bypass WebAuthn two-factor authentication during OAuth or OIDC sign-in to gain full account access in Gitea.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-gitea-2026-73278, GHSA-92j2-6qcg-c28c, MINI-3gjc-cf8g-cq8x, MINI-5ff7-jc28-rv5f

## What is CVE-2026-73278?

CVE-2026-73278 is a critical authentication bypass vulnerability in Gitea Gitea, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitea's OAuth2 and OpenID Connect sign-in paths do not require a WebAuthn challenge when WebAuthn is the account's only configured second factor. A party able to authenticate through the affected external identity flow can obtain a full session without the passkey verification enforced during password login. One affected path can also persist an external identity link, extending the compromise beyond the initial session; accounts with TOTP configured are outside the reported WebAuthn-only scenario.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-73278?

1 open source package ship an affected version, including gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitea` | Bitnami | From 1.16.0 | 1.27.2 |

Products: Gitea Gitea.

## How do I fix CVE-2026-73278?

Upgrade gitea to 1.27.2 or later.

## Is CVE-2026-73278 being exploited?

There is no known exploitation of CVE-2026-73278 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)
- [CVE-2021-45331](https://insights.sbomify.com/CVE-2021-45331/): Reuse of one time passwords allowed in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73278 and fix it if it is affected.

What it is: CVE-2026-73278 is a critical authentication bypass vulnerability in Gitea Gitea, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73278 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitea (Bitnami): affected from 1.16.0; fixed in 1.27.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73278/ (Markdown: https://insights.sbomify.com/CVE-2026-73278/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73278
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73278
- OSV: https://osv.dev/vulnerability/CVE-2026-73278

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73278/
Summaries are generated and may contain mistakes; the official description above is the record.
