# CVE-2026-73287: RustFS: FTPS MKD bypasses IAM CreateBucket authorization

> Authenticated FTPS users can bypass authorization checks to create buckets despite lacking S3 CreateBucket permissions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-g3vq-vv42-f647

## What is CVE-2026-73287?

CVE-2026-73287 is a medium-severity missing authorization vulnerability in rustfs, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RustFS is a distributed object storage system built in Rust. Prior to 1.0.0-beta.12, RustFS handles FTPS MKD in FtpsDriver::mkd in crates/protocols/src/ftps/driver.rs by calling storage.create_bucket without authorize_operation for S3Action::CreateBucket, allowing authenticated FTPS users denied s3:CreateBucket to create buckets. This issue is fixed in version 1.0.0-beta.12.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-73287?


## How do I fix CVE-2026-73287?

No fix has been published for CVE-2026-73287 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73287 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73287 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73287 and fix it if it is affected.

What it is: CVE-2026-73287 is a medium-severity missing authorization vulnerability in rustfs, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73287 exists.

Affected product: rustfs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73287/ (Markdown: https://insights.sbomify.com/CVE-2026-73287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73287
- OSV: https://osv.dev/vulnerability/CVE-2026-73287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73287/
Summaries are generated and may contain mistakes; the official description above is the record.
