# CVE-2026-73291: Seerr: Path traversal to RCE via /avatarproxy image cache filename from upstream ETag

> Attackers can exploit path traversal in the image proxy to overwrite files and execute code on the server.

- **Severity:** High 7.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-mc6w-69r3-62h8

## What is CVE-2026-73291?

CVE-2026-73291 is a high-severity path traversal vulnerability in seerr-team seerr, published on 12 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Seerr is an open-source media request and discovery manager for Jellyfin, Plex, and Emby. Prior to version 3.4.0, Seerr's ImageProxy in server/lib/imageproxy.ts uses the upstream ETag and Content-Type response headers to build a cache filename for the unauthenticated GET /avatarproxy/:jellyfinUserId route, allowing a malicious or compromised Jellyfin or Emby server, or a man-in-the-middle attacker on a plaintext media-server connection, to supply traversal sequences that path.join and fs.writeFile normalize outside the cache directory, overwrite /app/dist/index.js or other files, and execute code as the node user after a container restart. This issue is fixed in version 3.4.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-73291?


## How do I fix CVE-2026-73291?

No fix has been published for CVE-2026-73291 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73291 being exploited?

There is no known exploitation of CVE-2026-73291 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73291 and fix it if it is affected.

What it is: CVE-2026-73291 is a high-severity path traversal vulnerability in seerr-team seerr, published on 12 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73291 in the wild and no public exploit code.

Affected product: seerr-team seerr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73291/ (Markdown: https://insights.sbomify.com/CVE-2026-73291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73291
- OSV: https://osv.dev/vulnerability/CVE-2026-73291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73291/
Summaries are generated and may contain mistakes; the official description above is the record.
