# CVE-2026-73294: Semaphore U: OS Command Injection

> A project Manager or Owner can execute arbitrary OS commands on the Semaphore server by manipulating the git_url field in repository settings.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026

## What is CVE-2026-73294?

CVE-2026-73294 is a critical command injection vulnerability in semaphoreui semaphore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Semaphore UI is a web interface for managing DevOps tools. Prior to 2.18.17 and 2.19.5-beta2, repository git_url handling passes an attacker-controlled --upload-pack option to CmdGitClient.GetLastRemoteCommitHash through POST /api/project/{id}/repositories and scheduled commit-hash polling, allowing a project Manager or Owner to execute arbitrary OS commands in the Semaphore server process. This issue is fixed in versions 2.18.17 and 2.19.5-beta2.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-73294?


## How do I fix CVE-2026-73294?

Upgrade to a fixed version.

## Is CVE-2026-73294 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73294 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73294 and fix it if it is affected.

What it is: CVE-2026-73294 is a critical command injection vulnerability in semaphoreui semaphore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73294 exists.

Affected product: semaphoreui semaphore. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73294/ (Markdown: https://insights.sbomify.com/CVE-2026-73294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73294
- OSV: https://osv.dev/vulnerability/CVE-2026-73294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73294/
Summaries are generated and may contain mistakes; the official description above is the record.
