CVE-2026-73300 Budibase: SQL Injection via `multipleStatements: true`

Critical 9.6 Published Updated

Attackers can inject SQL commands via user input in Budibase's MySQL integration, leading to database compromise.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-73300?

CVE-2026-73300 is a critical SQL injection vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.

Weakness: CWE-89

Which versions are affected by CVE-2026-73300?

2 open source packages ship an affected version, including @budibase/server.

PackageAffectedFixed in
@budibase/server npmAll versions to 3.38.1None
@budibase/server npmAll versions to 3.38.1None

How do I fix CVE-2026-73300?

No fix has been published for CVE-2026-73300 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-73300 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73300 exists.

Sources

Also known as GHSA-q6x4-v3qx-85qw.

Is CVE-2026-73300 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free