{"answers":{"affected":"2 open source packages ship an affected version, including @budibase/server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73300 exists.","fix":"No fix has been published for CVE-2026-73300 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-73300 is a critical SQL injection vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-73300 and fix it if it is affected.\n\nWhat it is: CVE-2026-73300 is a critical SQL injection vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73300 exists.\n\nAffected packages and fixed versions:\n- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed\n- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73300/ (Markdown: https://insights.sbomify.com/CVE-2026-73300/index.md)","id":"CVE-2026-73300","markdown":"https://insights.sbomify.com/CVE-2026-73300/index.md","name":"CVE-2026-73300","record":{"aliases":["GHSA-q6x4-v3qx-85qw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Budibase low-code platform","requires_auth":"none","summary":"Attackers can inject SQL commands via user input in Budibase's MySQL integration, leading to database compromise.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Budibase: SQL Injection via `multipleStatements: true`","id":"CVE-2026-73300","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Budibase: Missing RBAC on GET /api/global/groups allows BASIC users to enumerate all tenant groups and role mappings","id":"CVE-2026-73301"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.38.1"],"package":"@budibase/server","purl":null,"source":"GHSA-q6x4-v3qx-85qw"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.38.1"],"package":"@budibase/server","purl":"pkg:npm/%40budibase/server","source":"GHSA-q6x4-v3qx-85qw"}],"prev":{"headline":"Prompty: Server-Side Template Injection to Remote Code Execution in the @prompty/core Nunjucks Renderer","id":"CVE-2026-73299"},"products":["budibase"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-12","vendors":["Budibase"]},"summary":"Attackers can inject SQL commands via user input in Budibase's MySQL integration, leading to database compromise.","url":"https://insights.sbomify.com/CVE-2026-73300/"}