# CVE-2026-73301: Budibase: Missing RBAC on GET /api/global/groups allows BASIC users to enumerate all tenant groups and role mappings

> Authenticated basic users can enumerate tenant groups and role mappings due to missing authorization checks on the groups API endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-4qcj-m5wp-jmf4

## What is CVE-2026-73301?

CVE-2026-73301 is a medium-severity missing authorization vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.25, the GET /api/global/groups endpoint in packages/worker/src/api/routes/global/groups.ts omitted auth.builderOrAdmin, allowing an authenticated BASIC role user to enumerate tenant groups, role mappings and user memberships, builder permissions, and default-group flags. The disclosure exposes the tenant access-control structure to users who are not builders or administrators. This issue is fixed in version 3.39.25.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-73301?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73301?

No fix has been published for CVE-2026-73301 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73301 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73301 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73301 and fix it if it is affected.

What it is: CVE-2026-73301 is a medium-severity missing authorization vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73301 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73301/ (Markdown: https://insights.sbomify.com/CVE-2026-73301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73301
- OSV: https://osv.dev/vulnerability/CVE-2026-73301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73301/
Summaries are generated and may contain mistakes; the official description above is the record.
