# CVE-2026-73302: Budibase: OIDC SSO account takeover: incoming identity linked by email without checking email_verified

> Attackers can take over victim accounts by exploiting OIDC SSO email verification bypass, inheriting victim roles and privileges.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-hp6v-6jw7-gv2f

## What is CVE-2026-73302?

CVE-2026-73302 is a critical authentication bypass vulnerability in budibase, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.30, the OIDC flow in packages/backend-core/src/middleware/passport/sso/oidc.ts resolved an email without getEmailVerified or an email_verified requirement, and packages/backend-core/src/middleware/passport/sso/sso.ts then used users.getGlobalUserByEmail as a fallback account-linking key. An attacker who can authenticate through a configured identity provider that asserts a victim email as unverified can have a fresh provider identity merged into the victim Budibase account and inherit the victim roles. This issue is fixed in version 3.39.30.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-73302?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73302?

No fix has been published for CVE-2026-73302 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73302 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73302 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73302 and fix it if it is affected.

What it is: CVE-2026-73302 is a critical authentication bypass vulnerability in budibase, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73302 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73302/ (Markdown: https://insights.sbomify.com/CVE-2026-73302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73302
- OSV: https://osv.dev/vulnerability/CVE-2026-73302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73302/
Summaries are generated and may contain mistakes; the official description above is the record.
