# CVE-2026-73303: Budibase: Email Change IDOR via POST /api/v2/email allows full Account Takeover (accountId not validated against session)

> Authenticated attackers can take over victim accounts by manipulating the email change workflow due to missing session validation on the account ID.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-c8vc-7pv3-g98p

## What is CVE-2026-73303?

CVE-2026-73303 is a high-severity authentication bypass vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.40.0, POST /api/v2/email on account.budibase.app accepted a client-controlled accountId without binding it to the authenticated session, while checking only currentEmail. An authenticated attacker who obtains a victim account identifier can start the email-change workflow for the victim, receive and submit the verification code through POST /api/v2/email/verification, move the victim email to an attacker-controlled address, and complete a password reset as the victim. This issue is fixed in version 3.40.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-73303?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73303?

No fix has been published for CVE-2026-73303 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73303 being exploited?

There is no known exploitation of CVE-2026-73303 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73303 and fix it if it is affected.

What it is: CVE-2026-73303 is a high-severity authentication bypass vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73303 in the wild and no public exploit code.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73303/ (Markdown: https://insights.sbomify.com/CVE-2026-73303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73303
- OSV: https://osv.dev/vulnerability/CVE-2026-73303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73303/
Summaries are generated and may contain mistakes; the official description above is the record.
