# CVE-2026-73304: Budibase: SSO OAuth2 Token Leakage via User Metadata Endpoints to Power-Role Users

> Power-role users can retrieve SSO OAuth2 tokens from user metadata endpoints, enabling persistent access to connected services.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-fcrw-f7gg-6g9f

## What is CVE-2026-73304?

CVE-2026-73304 is a medium-severity vulnerability in budibase, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.25, GET /api/users/metadata and GET /api/users/metadata/:id returned user objects processed by packages/server/src/utilities/global.ts without removing oauth2.accessToken or oauth2.refreshToken. A user with the POWER role could retrieve the identity-provider credentials of SSO-authenticated users and use the refresh tokens for persistent access to connected services. This issue is fixed in version 3.39.25.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-73304?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.39.25 |
| `@budibase/server` | npm | All versions | 3.39.25 |

## How do I fix CVE-2026-73304?

Upgrade @budibase/server to 3.39.25 or later.

## Is CVE-2026-73304 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73304 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73304 and fix it if it is affected.

What it is: CVE-2026-73304 is a medium-severity vulnerability in budibase, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73304 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.39.25
- @budibase/server (npm): affected all versions; fixed in 3.39.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73304/ (Markdown: https://insights.sbomify.com/CVE-2026-73304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73304
- OSV: https://osv.dev/vulnerability/CVE-2026-73304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73304/
Summaries are generated and may contain mistakes; the official description above is the record.
