# CVE-2026-73307: Budibase: SSRF via bare fetch() in uploadUrl during AI table generation

> A builder can exploit an SSRF vulnerability in AI table generation to access internal services or cloud metadata endpoints via unvalidated attachment URLs.

- **Severity:** Medium 4.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-hfhx-w8p8-4hc7

## What is CVE-2026-73307?

CVE-2026-73307 is a medium-severity server-side request forgery vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.4, uploadUrl in packages/server/src/utilities/fileUtils.ts used a bare server-side fetch for string attachment values passed by processAttachments in packages/server/src/sdk/workspace/ai/helpers/rows.ts. A builder with the AI table-generation feature could cause an attachment value to reference an internal service or cloud metadata endpoint, and the response would be stored as an attachment without fetchWithBlacklist validation. This issue is fixed in version 3.39.4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-73307?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73307?

No fix has been published for CVE-2026-73307 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73307 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73307 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73307 and fix it if it is affected.

What it is: CVE-2026-73307 is a medium-severity server-side request forgery vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73307 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73307/ (Markdown: https://insights.sbomify.com/CVE-2026-73307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73307
- OSV: https://osv.dev/vulnerability/CVE-2026-73307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73307/
Summaries are generated and may contain mistakes; the official description above is the record.
