# CVE-2026-73308: Budibase: OAuth2 Token Disclosure via Automation Test Results Broadcast to Other Builders

> A co-builder can obtain another user's OAuth2 tokens via unscoped automation test results, potentially leading to account takeover.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-gh4h-34gr-87r7

## What is CVE-2026-73308?

CVE-2026-73308 is a medium-severity vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.25, packages/server/src/api/controllers/automation.ts returned automation test results containing trigger.outputs.user.oauth2, broadcast BuilderSocketEvent.AutomationTestProgress to the app room, and stored progress in packages/server/src/automations/testProgress.ts without user scoping. A co-builder could receive or poll another SSO-authenticated builder test and obtain OAuth2 access and refresh tokens. The fix adds sanitizeAutomationTestResult and isolates progress by user. This issue is fixed in version 3.39.25.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-73308?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73308?

No fix has been published for CVE-2026-73308 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73308 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73308 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73308 and fix it if it is affected.

What it is: CVE-2026-73308 is a medium-severity vulnerability in budibase, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73308 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73308/ (Markdown: https://insights.sbomify.com/CVE-2026-73308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73308
- OSV: https://osv.dev/vulnerability/CVE-2026-73308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73308/
Summaries are generated and may contain mistakes; the official description above is the record.
