{"answers":{"affected":"2 open source packages ship an affected version, including @budibase/server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73407 exists.","fix":"No fix has been published for CVE-2026-73407 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-73407 is a critical server-side request forgery vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73407 and fix it if it is affected.\n\nWhat it is: CVE-2026-73407 is a critical server-side request forgery vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73407 exists.\n\nAffected packages and fixed versions:\n- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed\n- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73407/ (Markdown: https://insights.sbomify.com/CVE-2026-73407/index.md)","id":"CVE-2026-73407","markdown":"https://insights.sbomify.com/CVE-2026-73407/index.md","name":"CVE-2026-73407","record":{"aliases":["GHSA-mqhr-6j6h-74p5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Budibase low-code platform","requires_auth":"none","summary":"Unauthenticated attackers can steal stored REST datasource credentials by manipulating query paths to leak headers to attacker-controlled hosts.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Budibase is an open-source low-code platform. Prior to 3.40.1, RestIntegration._req in packages/server/src/integrations/rest.ts attached credentials from getAuthHeaders and defaultHeaders without requiring the final request destination to match the datasource origin. An unauthenticated caller of a PUBLIC POST /api/v2/queries/:queryId query could supply an absolute or parameterized path to an attacker-controlled host and receive the stored bearer, basic, or static-header credentials. This issue is fixed in version 3.40.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Budibase: Unauthenticated REST Datasource Credential Theft via Cross-Origin Auth Leak (bypass of CVE-2026-48152))","id":"CVE-2026-73407","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Budibase: MySQL DESCRIBE Backtick Injection via multipleStatements in Database Connector","id":"CVE-2026-73408"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.38.1"],"package":"@budibase/server","purl":null,"source":"GHSA-mqhr-6j6h-74p5"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.38.1"],"package":"@budibase/server","purl":"pkg:npm/%40budibase/server","source":"GHSA-mqhr-6j6h-74p5"}],"prev":{"headline":"Budibase: Unauthenticated user information disclosure via public tenant user lookup endpoint","id":"CVE-2026-73406"},"products":["budibase"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-12","vendors":["Budibase"]},"summary":"Unauthenticated attackers can steal stored REST datasource credentials by manipulating query paths to leak headers to attacker-controlled hosts.","url":"https://insights.sbomify.com/CVE-2026-73407/"}