# CVE-2026-73407: Budibase: Unauthenticated REST Datasource Credential Theft via Cross-Origin Auth Leak (bypass of CVE-2026-48152))

> Unauthenticated attackers can steal stored REST datasource credentials by manipulating query paths to leak headers to attacker-controlled hosts.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-mqhr-6j6h-74p5

## What is CVE-2026-73407?

CVE-2026-73407 is a critical server-side request forgery vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.40.1, RestIntegration._req in packages/server/src/integrations/rest.ts attached credentials from getAuthHeaders and defaultHeaders without requiring the final request destination to match the datasource origin. An unauthenticated caller of a PUBLIC POST /api/v2/queries/:queryId query could supply an absolute or parameterized path to an attacker-controlled host and receive the stored bearer, basic, or static-header credentials. This issue is fixed in version 3.40.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-73407?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73407?

No fix has been published for CVE-2026-73407 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73407 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73407 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73407 and fix it if it is affected.

What it is: CVE-2026-73407 is a critical server-side request forgery vulnerability in budibase, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73407 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73407/ (Markdown: https://insights.sbomify.com/CVE-2026-73407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73407
- OSV: https://osv.dev/vulnerability/CVE-2026-73407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73407/
Summaries are generated and may contain mistakes; the official description above is the record.
