# CVE-2026-73408: Budibase: MySQL DESCRIBE Backtick Injection via multipleStatements in Database Connector

> Attacker can execute arbitrary SQL via stacked queries in table names during schema discovery, requiring admin interaction.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-2xgg-r2wc-c5r2

## What is CVE-2026-73408?

CVE-2026-73408 is a high-severity SQL injection vulnerability in budibase, published on 13 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.18, packages/server/src/integrations/mysql.ts enabled multipleStatements and inserted an unescaped tableName into a DESCRIBE statement. An attacker able to create a MySQL table with a backtick and stacked statement in its name could wait for a Budibase administrator to run schema discovery, causing the second statement to execute. The fix applies quoteMySqlIdentifier before constructing the query. This issue is fixed in version 3.39.18.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-73408?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73408?

No fix has been published for CVE-2026-73408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73408 being exploited?

There is no known exploitation of CVE-2026-73408 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73408 and fix it if it is affected.

What it is: CVE-2026-73408 is a high-severity SQL injection vulnerability in budibase, published on 13 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-73408 in the wild and no public exploit code.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73408/ (Markdown: https://insights.sbomify.com/CVE-2026-73408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73408
- OSV: https://osv.dev/vulnerability/CVE-2026-73408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73408/
Summaries are generated and may contain mistakes; the official description above is the record.
