# CVE-2026-73409: Budibase: Server Filesystem Existence/Read Oracle via Builder-Controlled MongoDB tlsCertificateKeyFile

> A builder can determine the existence and readability of server files by manipulating MongoDB TLS certificate paths, exposing sensitive filesystem information.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-ppr4-5f46-j9c6

## What is CVE-2026-73409?

CVE-2026-73409 is a medium-severity vulnerability in budibase, published on 12 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.40.1, packages/server/src/integrations/mongodb.ts passed builder-controlled tlsCertificateKeyFile and tlsCAFile values directly to MongoClient on Budibase Cloud. A builder could submit absolute server paths through /api/datasources/verify and distinguish readable existing files from missing files by comparing the driver error, exposing a filesystem existence and readability oracle on the shared server. This issue is fixed in version 3.40.1.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2026-73409?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73409?

No fix has been published for CVE-2026-73409 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73409 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73409 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73409 and fix it if it is affected.

What it is: CVE-2026-73409 is a medium-severity vulnerability in budibase, published on 12 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73409 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73409/ (Markdown: https://insights.sbomify.com/CVE-2026-73409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73409
- OSV: https://osv.dev/vulnerability/CVE-2026-73409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73409/
Summaries are generated and may contain mistakes; the official description above is the record.
