# CVE-2026-73410: Budibase: SSRF via DNS rebinding in the REST datasource integration

> A builder can exploit DNS rebinding in the REST datasource integration to access internal network resources and bypass validation controls.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-v42f-v8xc-j435

## What is CVE-2026-73410?

CVE-2026-73410 is a high-severity server-side request forgery vulnerability in budibase, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.40.0, packages/backend-core/src/utils/outboundFetch.ts pinned a validated address through a Node agent, but the REST integration used getDispatcher from packages/backend-core/src/utils/fetch.ts, causing undici to ignore that agent and resolve the hostname again. A builder could use DNS rebinding to make packages/server/src/integrations/rest.ts connect to an internal address after a public address passed validation, with full response access and arbitrary REST methods. The fix adds createPinnedLookup support to the undici dispatcher and passes the validated address to custom fetch implementations. This issue is fixed in version 3.40.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-73410?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions to 3.38.1 | None |
| `@budibase/server` | npm | All versions to 3.38.1 | None |

## How do I fix CVE-2026-73410?

No fix has been published for CVE-2026-73410 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73410 being exploited?

There is no known exploitation of CVE-2026-73410 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73410 and fix it if it is affected.

What it is: CVE-2026-73410 is a high-severity server-side request forgery vulnerability in budibase, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73410 in the wild and no public exploit code.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed
- @budibase/server (npm): affected all versions up to 3.38.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73410/ (Markdown: https://insights.sbomify.com/CVE-2026-73410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73410
- OSV: https://osv.dev/vulnerability/CVE-2026-73410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73410/
Summaries are generated and may contain mistakes; the official description above is the record.
