# CVE-2026-73414: Shescape: Shell injection via unescaped parentheses on Windows with CMD

> An attacker can execute arbitrary commands on Windows by injecting unescaped parentheses into arguments processed by the Shescape library.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-w4hw-qcx7-56pr

## What is CVE-2026-73414?

CVE-2026-73414 is a critical command injection vulnerability in ericcornelissen shescape, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shescape is a simple shell escape library for JavaScript. Prior to 2.1.14 and 3.0.1, getEscapeFunction in src/internal/win/cmd.js does not escape `(` and `)` when applications use the escape or escapeAll APIs on Windows with shell set to cmd.exe, or with shell set to true when CMD is the default. An attacker-controlled argument can break out of a parenthesized CMD construct and inject shell syntax depending on the original command, resulting in arbitrary command execution. This issue is fixed in versions 2.1.14 and 3.0.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-73414?

4 open source packages ship an affected version, including shescape.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shescape` | npm | All versions | 2.1.14 |
| `shescape` | npm | All versions | 2.1.14 |
| `shescape` | npm | From 3.0.0 | 3.0.1 |
| `shescape` | npm | From 3.0.0 | 3.0.1 |

## How do I fix CVE-2026-73414?

Upgrade shescape to a fixed version for your release line: 2.1.14 or 3.0.1.

## Is CVE-2026-73414 being exploited?

There is no known exploitation of CVE-2026-73414 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73414 and fix it if it is affected.

What it is: CVE-2026-73414 is a critical command injection vulnerability in ericcornelissen shescape, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73414 in the wild and no public exploit code.

Affected packages and fixed versions:
- shescape (npm): affected all versions; fixed in 2.1.14
- shescape (npm): affected all versions; fixed in 2.1.14
- shescape (npm): affected from 3.0.0; fixed in 3.0.1
- shescape (npm): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73414/ (Markdown: https://insights.sbomify.com/CVE-2026-73414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73414
- OSV: https://osv.dev/vulnerability/CVE-2026-73414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73414/
Summaries are generated and may contain mistakes; the official description above is the record.
