CVE-2026-73418 NextAuth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers

High 7.5 Published Updated

An attacker can cause a denial of service by sending malformed Bearer headers, triggering uncaught exceptions in NextAuth.js authentication handlers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-73418?

CVE-2026-73418 is a high-severity denial of service vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the exported getToken() helper in the next-auth/jwt and @auth/core/jwt modules can throw an uncaught exception when it reads a malformed Authorization: Bearer header. When no session cookie is present, getToken() URL-decodes the bearer value before validating it, and malformed percent encoding causes decodeURIComponent() to throw instead of treating the token as invalid. Because getToken() is commonly called in API routes, middleware, and server-side request handlers, a single unauthenticated request can trigger an unhandled exception in code paths that authenticate requests, causing a per-request denial of service without exposing tokens, sessions, or other data and without bypassing authentication. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

Weakness: CWE-248, CWE-20

Which versions are affected by CVE-2026-73418?

6 open source packages ship an affected version, including @auth/core and next-auth.

PackageAffectedFixed in
@auth/core npmFrom 0.1.00.41.3
@auth/core npmFrom 0.1.00.41.3
next-auth npmFrom 4.0.64.24.15
next-auth npmFrom 4.0.64.24.15
next-auth npmFrom 5.0.0-beta.05.0.0-beta.32
next-auth npmFrom 5.0.0-beta.05.0.0-beta.32

How do I fix CVE-2026-73418?

Upgrade @auth/core to 0.41.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-73418 being exploited?

There is no known exploitation of CVE-2026-73418 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-KD45658, CLEANSTART-2026-PL55770, ECHO-bdc4-d206-ec90, GHSA-xmf8-cvqr-rfgj, MINI-776f-qxfw-jxc9.

Is CVE-2026-73418 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free