{"answers":{"affected":"6 open source packages ship an affected version, including @auth/core and next-auth.","exploited":"There is no known exploitation of CVE-2026-73418 in the wild and no public exploit code.","fix":"Upgrade @auth/core to 0.41.3 or later.","what":"CVE-2026-73418 is a high-severity denial of service vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73418 and fix it if it is affected.\n\nWhat it is: CVE-2026-73418 is a high-severity denial of service vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @auth/core (npm): affected from 0.1.0; fixed in 0.41.3\n- @auth/core (npm): affected from 0.1.0; fixed in 0.41.3\n- next-auth (npm): affected from 4.0.6; fixed in 4.24.15\n- next-auth (npm): affected from 4.0.6; fixed in 4.24.15\n- next-auth (npm): affected from 5.0.0-beta.0; fixed in 5.0.0-beta.32\n- next-auth (npm): affected from 5.0.0-beta.0; fixed in 5.0.0-beta.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73418/ (Markdown: https://insights.sbomify.com/CVE-2026-73418/index.md)","id":"CVE-2026-73418","markdown":"https://insights.sbomify.com/CVE-2026-73418/index.md","name":"CVE-2026-73418","record":{"aliases":["CLEANSTART-2026-KD45658","CLEANSTART-2026-PL55770","ECHO-bdc4-d206-ec90","GHSA-xmf8-cvqr-rfgj","MINI-776f-qxfw-jxc9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"NextAuth.js authentication library","requires_auth":"none","summary":"An attacker can cause a denial of service by sending malformed Bearer headers, triggering uncaught exceptions in NextAuth.js authentication handlers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the exported getToken() helper in the next-auth/jwt and @auth/core/jwt modules can throw an uncaught exception when it reads a malformed Authorization: Bearer header. When no session cookie is present, getToken() URL-decodes the bearer value before validating it, and malformed percent encoding causes decodeURIComponent() to throw instead of treating the token as invalid. Because getToken() is commonly called in API routes, middleware, and server-side request handlers, a single unauthenticated request can trigger an unhandled exception in code paths that authenticate requests, causing a per-request denial of service without exposing tokens, sessions, or other data and without bypassing authentication. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NextAuth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers","id":"CVE-2026-73418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":7,"next":{"headline":"NextAuth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them","id":"CVE-2026-73419"},"packages":[{"ecosystem":"npm","fixed":["0.41.3"],"introduced":["0.1.0"],"last_affected":[],"package":"@auth/core","purl":null,"source":"GHSA-xmf8-cvqr-rfgj"},{"ecosystem":"npm","fixed":["0.41.3"],"introduced":["0.1.0"],"last_affected":[],"package":"@auth/core","purl":"pkg:npm/%40auth/core","source":"GHSA-xmf8-cvqr-rfgj"},{"ecosystem":"npm","fixed":["4.24.15"],"introduced":["4.0.6"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-xmf8-cvqr-rfgj"},{"ecosystem":"npm","fixed":["4.24.15"],"introduced":["4.0.6"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-xmf8-cvqr-rfgj"},{"ecosystem":"npm","fixed":["5.0.0-beta.32"],"introduced":["5.0.0-beta.0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-xmf8-cvqr-rfgj"},{"ecosystem":"npm","fixed":["5.0.0-beta.32"],"introduced":["5.0.0-beta.0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-xmf8-cvqr-rfgj"}],"prev":{"headline":"JupyterLab: Cross-site scripting (XSS) via crafted settings file (`overrides.json`)","id":"CVE-2026-73417"},"products":["core","next-auth"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-13","vendors":["@auth","nextauthjs"]},"summary":"An attacker can cause a denial of service by sending malformed Bearer headers, triggering uncaught exceptions in NextAuth.js authentication handlers.","url":"https://insights.sbomify.com/CVE-2026-73418/"}