# CVE-2026-73418: NextAuth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers

> An attacker can cause a denial of service by sending malformed Bearer headers, triggering uncaught exceptions in NextAuth.js authentication handlers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLEANSTART-2026-KD45658, CLEANSTART-2026-PL55770, ECHO-bdc4-d206-ec90, GHSA-xmf8-cvqr-rfgj, MINI-776f-qxfw-jxc9

## What is CVE-2026-73418?

CVE-2026-73418 is a high-severity denial of service vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the exported getToken() helper in the next-auth/jwt and @auth/core/jwt modules can throw an uncaught exception when it reads a malformed Authorization: Bearer header. When no session cookie is present, getToken() URL-decodes the bearer value before validating it, and malformed percent encoding causes decodeURIComponent() to throw instead of treating the token as invalid. Because getToken() is commonly called in API routes, middleware, and server-side request handlers, a single unauthenticated request can trigger an unhandled exception in code paths that authenticate requests, causing a per-request denial of service without exposing tokens, sessions, or other data and without bypassing authentication. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

Weakness: CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-73418?

6 open source packages ship an affected version, including @auth/core and next-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@auth/core` | npm | From 0.1.0 | 0.41.3 |
| `@auth/core` | npm | From 0.1.0 | 0.41.3 |
| `next-auth` | npm | From 4.0.6 | 4.24.15 |
| `next-auth` | npm | From 4.0.6 | 4.24.15 |
| `next-auth` | npm | From 5.0.0-beta.0 | 5.0.0-beta.32 |
| `next-auth` | npm | From 5.0.0-beta.0 | 5.0.0-beta.32 |

## How do I fix CVE-2026-73418?

Upgrade @auth/core to 0.41.3 or later.

## Is CVE-2026-73418 being exploited?

There is no known exploitation of CVE-2026-73418 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73418 and fix it if it is affected.

What it is: CVE-2026-73418 is a high-severity denial of service vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73418 in the wild and no public exploit code.

Affected packages and fixed versions:
- @auth/core (npm): affected from 0.1.0; fixed in 0.41.3
- @auth/core (npm): affected from 0.1.0; fixed in 0.41.3
- next-auth (npm): affected from 4.0.6; fixed in 4.24.15
- next-auth (npm): affected from 4.0.6; fixed in 4.24.15
- next-auth (npm): affected from 5.0.0-beta.0; fixed in 5.0.0-beta.32
- next-auth (npm): affected from 5.0.0-beta.0; fixed in 5.0.0-beta.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73418/ (Markdown: https://insights.sbomify.com/CVE-2026-73418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73418
- OSV: https://osv.dev/vulnerability/CVE-2026-73418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73418/
Summaries are generated and may contain mistakes; the official description above is the record.
