{"answers":{"affected":"6 open source packages ship an affected version, including @auth/core and next-auth.","exploited":"There is no known exploitation of CVE-2026-73419 in the wild and no public exploit code.","fix":"Upgrade @auth/core to 0.41.3 or later.","what":"CVE-2026-73419 is a medium-severity authentication bypass vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-73419 and fix it if it is affected.\n\nWhat it is: CVE-2026-73419 is a medium-severity authentication bypass vulnerability in @auth core, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-73419 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @auth/core (npm): affected all versions; fixed in 0.41.3\n- @auth/core (npm): affected all versions; fixed in 0.41.3\n- next-auth (npm): affected all versions; fixed in 4.24.15\n- next-auth (npm): affected all versions; fixed in 4.24.15\n- next-auth (npm): affected from 5.0.0-beta.1; fixed in 5.0.0-beta.32\n- next-auth (npm): affected from 5.0.0-beta.1; fixed in 5.0.0-beta.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73419/ (Markdown: https://insights.sbomify.com/CVE-2026-73419/index.md)","id":"CVE-2026-73419","markdown":"https://insights.sbomify.com/CVE-2026-73419/index.md","name":"CVE-2026-73419","record":{"aliases":["CLEANSTART-2026-HJ83512","CLEANSTART-2026-JW21689","ECHO-4bf4-a83a-db7c","GHSA-x445-f3h2-j279","MINI-97pm-49wj-qr65"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"NextAuth.js authentication library","requires_auth":"none","summary":"Attackers can link their account to a victim's profile in multi-provider NextAuth.js apps, gaining persistent access to the victim's account.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-940","name":"Improper Verification of Source of a Communication Channel"},{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"NextAuth.js provides authentication for Next.js. Prior to@auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, Auth.js stores the OAuth/OIDC anti-CSRF checks state, nonce, and the PKCE verifier in global cookies that are not bound to the provider that created them. On callback, a check value minted during a sign-in started with one provider can satisfy the callback for a different provider because the stored cookie is not verified against the callback provider's identity, including the provider ID, issuer, client ID, or redirect URI. In a multi-provider application that permits account linking while logged in, when one provider's authorization request is observable and a target provider callback can be satisfied without a PKCE verifier, an attacker can lure a victim into starting a legitimate same-origin flow and link the attacker's target-provider account to the victim's Auth.js user. The linked provider grants the attacker persistent sign-in to the victim's account, while cross-site request forgery alone is insufficient. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NextAuth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them","id":"CVE-2026-73419","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":6,"n_references":7,"next":{"headline":"NextAuth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass","id":"CVE-2026-73420"},"packages":[{"ecosystem":"npm","fixed":["0.41.3"],"introduced":["0"],"last_affected":[],"package":"@auth/core","purl":null,"source":"GHSA-x445-f3h2-j279"},{"ecosystem":"npm","fixed":["0.41.3"],"introduced":["0"],"last_affected":[],"package":"@auth/core","purl":"pkg:npm/%40auth/core","source":"GHSA-x445-f3h2-j279"},{"ecosystem":"npm","fixed":["4.24.15"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-x445-f3h2-j279"},{"ecosystem":"npm","fixed":["4.24.15"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-x445-f3h2-j279"},{"ecosystem":"npm","fixed":["5.0.0-beta.32"],"introduced":["5.0.0-beta.1"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-x445-f3h2-j279"},{"ecosystem":"npm","fixed":["5.0.0-beta.32"],"introduced":["5.0.0-beta.1"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-x445-f3h2-j279"}],"prev":{"headline":"NextAuth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers","id":"CVE-2026-73418"},"products":["core","next-auth"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-13","vendors":["@auth","nextauthjs"]},"summary":"Attackers can link their account to a victim's profile in multi-provider NextAuth.js apps, gaining persistent access to the victim's account.","url":"https://insights.sbomify.com/CVE-2026-73419/"}