CVE-2026-73420 NextAuth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass
Attackers can hijack user accounts by exploiting Unicode normalization flaws in email validation to misroute magic-link sign-in emails.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73420?
CVE-2026-73420 is a critical authentication bypass vulnerability in @auth core, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the defaultNormalizer used by the email and magic-link sign-in flow validates an address before applying Unicode normalization. An address can contain a Unicode character such as U+FF20 FULLWIDTH COMMERCIAL AT that is not ASCII at-sign but canonicalizes to an ASCII at-sign under NFKC or NFKD normalization. The address passes the normalizer's single-at-sign check, but a downstream sendVerificationRequest mail library or delivery service that normalizes the address can then see two at-sign separators and deliver the passwordless sign-in link to an attacker-controlled recipient. Applications are affected when the email provider uses the built-in normalizer rather than a custom normalizeIdentifier and the downstream sender applies Unicode normalization. An attacker who knows a victim's email address can request the misrouted magic link and sign in as the victim without victim interaction. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.
Weakness: CWE-180
Which versions are affected by CVE-2026-73420?
6 open source packages ship an affected version, including @auth/core and next-auth.
| Package | Affected | Fixed in |
|---|---|---|
@auth/core npm | From 0.1.0 | 0.41.3 |
@auth/core npm | From 0.1.0 | 0.41.3 |
next-auth npm | From 4.10.3 | 4.24.15 |
next-auth npm | From 4.10.3 | 4.24.15 |
next-auth npm | From 5.0.0-beta.1 | 5.0.0-beta.32 |
next-auth npm | From 5.0.0-beta.1 | 5.0.0-beta.32 |
How do I fix CVE-2026-73420?
Upgrade @auth/core to 0.41.3 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-73420 being exploited?
There is no known exploitation of CVE-2026-73420 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-PJ45513, CLEANSTART-2026-UY65626, ECHO-2dd4-1209-8fa6, GHSA-7rqj-j65f-68wh, MINI-9rhj-8fjf-x394, MINI-hqcv-vx43-gc7f and 1 more.