# CVE-2026-73426: Trix: Stored XSS vulnerability through serialized attributes

> Attackers can execute arbitrary JavaScript in user sessions via malicious serialized attributes in the Trix rich text editor library.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-qmpg-8xg6-ph5q

## What is CVE-2026-73426?

CVE-2026-73426 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Prior to 2.1.17, Trix is vulnerable to cross-site scripting when a data-trix-serialized-attributes attribute bypasses the DOMPurify sanitizer. An attacker can craft HTML containing a data-trix-serialized-attributes attribute with a malicious payload that, when rendered, executes arbitrary JavaScript in the user's session and may perform unauthorized actions or disclose sensitive information. This issue is fixed in version 2.1.17.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-73426?

4 open source packages ship an affected version, including action_text-trix and trix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `action_text-trix` | RubyGems | All versions | 2.1.17 |
| `action_text-trix` | RubyGems | All versions | 2.1.17 |
| `trix` | npm | All versions | 2.1.17 |
| `trix` | npm | All versions | 2.1.17 |

## How do I fix CVE-2026-73426?

Upgrade action_text-trix to 2.1.17 or later.

## Is CVE-2026-73426 being exploited?

There is no known exploitation of CVE-2026-73426 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73426 and fix it if it is affected.

What it is: CVE-2026-73426 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-73426 in the wild and no public exploit code.

Affected packages and fixed versions:
- action_text-trix (RubyGems): affected all versions; fixed in 2.1.17
- action_text-trix (RubyGems): affected all versions; fixed in 2.1.17
- trix (npm): affected all versions; fixed in 2.1.17
- trix (npm): affected all versions; fixed in 2.1.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73426/ (Markdown: https://insights.sbomify.com/CVE-2026-73426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73426
- OSV: https://osv.dev/vulnerability/CVE-2026-73426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73426/
Summaries are generated and may contain mistakes; the official description above is the record.
